First aid kit

From LabNation
Jump to: navigation, search

SmartScope not connecting to your host device

Firstly, we almost never have DOAs, so we're happy to assist you and look into your specific case which can be done by contacting us at support@lab-nation.com.


But as a first step, you can already go through the procedure below.
Start by trying to hook up the SmartScope to a regular pc or laptop, running Windows, MacOS or Linux.
You can download the software from https://www.lab-nation.com/app and install it. After launching the software and connecting the scope, things should be working and the USB logo on the bottom-right of the app should be green.


If it doesn't: please contact us at support@lab-nation.com and let us know at which step it doesn't work.
If the USB icon stays red: please include the smartscope.log file, which you can find at the following location:

Platform CrashReport path
Mac /Users/<username>/LabNation
Linux ~/LabNation
Windows <My Documents>/LabNation
Android <sd-card>/LabNation

Crashing at startup because of corrupt settings file

In case the program used to work, but now crashes at startup, there's a chance there might be a corrupt setting stored which causes the crash during the initialization phase.
In order to solve this, you can simply remove the settings file. However, before removing the file, please send it to bughunt@lab-nation.com, as this gives us the rare opportunity to exactly reproduce the crash and solve it at the root!!

The settings file is stored at the following location:

  • Windows: C:\Users\[yourUser]\AppData\Local\LabNation\default.xml (AppData is a hidden folder)
  • Linux: ~/.local/share/LabNation/default.xml
  • Android: Ideally you can access this file by connecting with a USB cable to your PC. Alternatively you can simply fix the issue by deleting the App data (in Android Settings > Apps > SmartScope > Storage > Clear Data).

Regarding this file, please:

  • first send it to bughunt@lab-nation.com
  • then delete it (with the app closed)
  • restart the app

Windows: cannot install new version of software/driver

In case:

  • you get an error message during the installation of the SmartScope app ("There is a problem with this Windows Installer package...")

or

  • the SmartScope app cannot find the SmartScope (USB icon remains red) even when a SmartScope is actually connected

make sure you go through the following checklist:

  1. make sure all programs are closed; especially those which might be accessing the SmartScope; and try running the installer again.
  2. ensure the 'Windows Update' service is running. To do so, run 'msconfig' and go to Services tab. Find Windows Update, and make sure the checkbox is ticked. (you can disable it again after the installation, but for some reason Windows likes to check whether it finds a newer driver than the one in our install package)
  3. restart your Windows machine and try running the installer again.
  4. in the SmartScope app, go to Menu -> System -> Install driver (which does essentially the same as the driver part in the installer..)
  5. In Windows, start Device Manager. Verify if you have an entry 'Universal Serial Bus devices' -> SmartScope. Right-click and make sure you check 'Delete the driver software for this device'. Unplug and replug the SmartScope. Try either of steps 1-2-3 to install the driver again.